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                                                                日本語版日本語版日本語版日本語版についてについてについてについて    

    

 この日本語版マニュアルは、Tosmana User Manual(http://www.tosmana.net/)を日本語に翻

訳したものである。翻訳は森大輔（東京大学法学政治学研究科助教）が行った。 

 Tosmana は、質的比較分析(QCA)のためのソフトウェアであり、中でも多値質的比較分析

(mvQCA)を行えることが一番の特徴となっている。また、閾値の設定を視覚的に行うことがで

きたり、ブール式をグラフィカルに表現したりできるなど、非常にユーザーフレンドリな作りに

なっている。 

    このマニュアルは、バージョン 1.3betaをもとにしているので、現在配布されているバージョ

ン 1.3.1と若干異なる部分がある。そうした部分を中心に、いくつか訳注を付した。 

    最後に、日本語版の作成を快く認めてくださった Lasse Cronqvist氏に感謝の意を表したい。 

    なお、この日本語版へのご質問、誤りのご指摘などは、mdai@ad.wakwak.comまでご連絡い

ただきたい。 

                                                                                                                                            森 大輔 

                                                                                                                                     2010年 2月 
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1. 1. 1. 1. はじめにはじめにはじめにはじめに 

 この文書は、Tool for Small-N Analysis(Tosmana)の簡単な手引書である。質的比較分析(QCA)

はTosmanaに実装されている主要な手法なので、その基本的な特徴は説明されるものの、本文書

はこの手法の入門書ではない。QCAは、チャールズ・レイガンの『社会科学における比較研究』

1によって初めて社会科学に導入された。彼はこの本において、量的分析と質的分析の2つのアプ

ローチの強みを統合し問題点を減らす新しい手法を導入することで、2つのアプローチの間にあ

るギャップを乗り越えようとしている。それが質的比較分析(Qualitative Comparative Analysis, 

QCA)である。QCAの主要な目標は、ブール代数を使うことでデータセットの複雑性を減らすこ

とである。1987年以来、この手法を実装したいくつかのプログラムが作られてきた。新しいプ

ログラムになるごとに、いくつかの変化が起こった。例えば、新しいアルゴリズムが導入され、

よりパワフルなコンピューターの登場により、同時に扱える条件の数に関する限界が引き上げら

れた。fsQCA(Fuzzy Set Qualitative Comparative Analysis, http://www.fsqca.com)において、

グラフィカルユーザーインターフェース（ウィンドウズのスタイル）が初めて使われ、QCA3が

持っていた12個の様々な限界が克服された。Tosmanaは古典的なブール代数も実装するが、QCA

の主要な限界の1つである「{上、中、下}といったふうにより多くの条件値を使いたいことがし

ばしばあるにもかかわらず、データセットの要素はすべてT(真)かF(偽)でなければならない」と

いうブール集合の制約に対処することが目的である。したがって、Tosmanaはブール代数の簡単

化のためにも使えるが、追加機能として多値の場合(MVQCA)の簡単化も導入している。この文

書はソフトウェアのマニュアルなので手法自体は議論しないが、多値の場合の簡単化に関する入

門はウェブ上で読むことができる2(訳注1)。Tosmanaのリソースサイト

(http://www.tosmana.net/resources/)には、さらなる論文のリストがあるので見ていただきたい。 

 

なお、Tosmanaは開発途上であり、ソフトウェアの詳細な部分が多数変更される可能性がある。 

 

2. Tosmana2. Tosmana2. Tosmana2. Tosmana ののののインストールインストールインストールインストール 

 バージョン1.3以来、Tosmanaにはインストールの全プロセスを導いてくれるインストーラー

が付属している。 

 Tosmanaは、.NET Frameworkというマイクロソフトが提供しているプログラミング・プラ

ットフォームを使用している。この.NET Frameworkを使用する利点は、ソフトウェア作成の細

部の多くを代行してくれ、プログラマーは中心的な題材に集中できることである。つまり、.NET 

Frameworkを使った方がずっと速くTosmanaを作成できる。しかしこれは、ユーザーのシステ

ムに.NET Frameworkがインストールされていない場合には、.NET Frameworkのインストー

ルをしなければならないということでもある。バージョン1.3以降、必要であればインストーラ

                                                   
1 Ragin (1987). 
2 Cronqvist (2003).  
訳注 1 日本語で読める多値の場合のブール代数への入門としては、鹿又伸夫ほか編(2001)の第 12
章がある。 
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ーにより.NET Frameworkがインストールされるようになっている。 

 

3.3.3.3.    メインウィンドウメインウィンドウメインウィンドウメインウィンドウ 

 .NET Frameworkが正しくインストールされていれば、Tosmanaはエクスプローラーやスタ

ートメニューのようなウィンドウズのプログラムから簡単に起動できる。Tosmanaが起動すると、

メインウィンドウが現れる。メインウィンドウでは、データファイルの作成・読み込み・保存を

行ったり、計算ウィンドウを呼び出したりする。 

 

 

 開かれたファイルはメインウィンドウに表示される。メインウィンドウのメニューバーから、

データの操作と分析のための全てのツールを呼び出すことができる（下記参照）。データセット

のデータがメインウィンドウに表示され、それを直接編集することができる。 

 メインウィンドウに、変数の全ての情報が直接表示されている。緑の旗のついた変数名の列に

は数値のデータを含んではならず、この列は事例ID(case ID)としてしか使うことができない。

変数名のすぐ下にある数字は、(MV)QCAのデータセットの作成のために使われる閾値

(threshold)である。変数名の下に警告マークがついている場合は、閾値を設定しなければならな

いということを意味する。QCAやMVQCAの分析用に再コーディングされたデータは、MVQCA 

Dataタブに表示される。 

 

4. 4. 4. 4. データセットデータセットデータセットデータセット    

ファイルファイルファイルファイルのののの作成作成作成作成とととと保存保存保存保存    

 File→Newと選択することで、新しいTosmanaのデータセットが作成される。メニューバーか

らData→New Variableと選択することで、データセットに変数を追加することができる。全て

の変数を追加したら、メインウィンドウのデータマトリックスに事例の情報を入力するだけで、

データセットの事例を追加できる。変数の名前や他の情報を変更するには、メインウィンドウ上

のその変数の列のヘッダー（見出し）をクリックして、Edit Variableを選択する。 

 メニューバーからFile→Saveと選択することで、データセットを保存できる。データセットを

他のアプリケーション（ExcelやfsQCA）で使用したい場合は、csvやdatファイルとして保存す
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ればよい（Exportを選択する）。ファイルはXML形式で保存されるが、拡張子には.tosmanaが

割り当てられる。この拡張子のファイルを選択すると、エクスプローラーからそのファイルを

Tosmanaで直接開くことができる。 

 

データデータデータデータのののの読読読読みみみみ込込込込みとみとみとみとインポートインポートインポートインポート    

TosmanaTosmanaTosmanaTosmanaへのへのへのへのファイルファイルファイルファイルのののの読読読読みみみみ込込込込みみみみ    

 メインウィンドウのメニューバーからFile→Openを選択することで、Tosmanaで作成した（そ

して保存した）ファイルを読み込むことができる。Tosmanaで作成してXML（拡張マークアッ

プ言語）形式かTosmana形式で保存したファイルのみを、Openで読み込むよう注意する。拡張

子.tosmanaのファイルは普通のXMLファイルだが、この独特な拡張子を使うことで、データフ

ァイルを開くとTosmanaが起動するようにしている。ファイルをこのTosmana形式で保存する

と、エクスプローラーからそのファイルをTosmanaで直接開くことができる。 

 

ExcelExcelExcelExcelからのからのからのからのインポートインポートインポートインポート    

 File→Import→Excel or fsqca (csv file)と選択することで、Excelで保存されたCSV形式のファ

イルをTosmanaにインポートできる（この機能はExcel97とExcel2000でテストしたが、他のバ

ージョンでも恐らくうまく機能する)。まず、事例IDとして使われる変数が、データセットに含

まれていることを確認しなければならない。ExcelからTosmanaにデータをインポートするには、

以下のようにする: 

Excel側で 

1. データセットをExcelで開く。 

2. Tosmanaにエクスポートするシートに切り替える。 

3. ファイル→名前を付けて保存 を選択し、「CSV（カンマ区切り）(*.csv)」をダイアログボッ

クスにおいて選択する。 

4. ファイルの名前を入力し、ファイルを保存する。 

5. ワークシートを閉じる。 

Tosmana側で 

Tosmanaで、File→Import→Excel or fsqca (csv file)を選択し、今保存したファイルを選択する。

Tosmanaのインポート機能は、変数のタイプ（事例ID、間隔尺度、順序尺度）を識別する。こ

れらの設定を確認すると、データがTosmanaのメインウィンドウに現れる。 データをTosmana

形式かXML形式で保存しておく。 

 

SPSSSPSSSPSSSPSSからのからのからのからのデータデータデータデータののののインポートインポートインポートインポート    

 File→Import→SPSS (dat file)と選択することで、SPSSのDAT形式のファイルもインポート

できる。Excelのインポートと同様に、事例IDとして使われる変数が、データセットに含まれて

いることをまず確認しなければならない。全ての変数が名義尺度であると識別されることに注意

する。この設定の変更は変数の設定(variable settings)において扱う訳注2。ExcelからTosmanaに

                                                   
訳注 2現在のバージョン1.3.1では、Edit Variableメニューで閾値を設定すれば設定が変更される。 
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データをインポートするには、以下のようにする: 

SPSS側で 

1. データセットをSPSSで開く。 

2. ファイル→名前を付けて保存 を選択し、ダイアログボックスで「Tab-delimited (*.dat)」を

ファイルの種類として選択する。 

3. ファイルの名前を入力し、ファイルを保存する。 

4. ワークシートを閉じる。 

Tosmana側で 

Tosmanaで、File→Import→SPSS (dat file)を選択し、今保存したファイルを選択する。すると、

データがTosmanaのメインウィンドウに現れる。 データをTosmana形式かXML形式で保存して

おく。 

 

fsQCAfsQCAfsQCAfsQCAからのからのからのからのデータデータデータデータののののインポートインポートインポートインポート    

 File→Import→Excel or fsqca (csv file)と選択することで、fsQCAのCSV形式のファイルもイ

ンポートできる。まず、事例IDとして使われる変数が、データセットに含まれていることを確

認しなければならない。全ての変数が名義尺度であると識別されることに注意する。この設定の

変更は変数の設定(variable settings)において扱う。fsQCAからTosmanaにデータをインポート

するには、以下のようにする: 

fsQCA側で 

1. データセットをfsQCAで開く。 

2. File→Save aS を選択する。ダイアログウィンドウが出現するので、File Typeとして"comma"

を選択する。 

3. ファイルの名前を入力する。 

4. ファイルを保存する。 

Tosmana側で 

Tosmanaで、File→Import→Excel or fsqca (csv file)を選択し、今保存したファイルを選択する。

すると、データがTosmanaのメインウィンドウに現れる。 データをTosmana形式かXML形式で

保存しておく。 

 

データセットデータセットデータセットデータセットのののの編集編集編集編集    

 メインウィンドウのデータを変更することで、データマトリックスの内容をいつでも変更する

ことができる。新しいデータを使って計算を行うには、新しい計算ウィンドウを開かなくてはな

らないことに注意すること。新しい行（事例）を付け加えたい場合は、データセットの最後の行

に入力すればよい。事例を削除したい場合は、その事例のある行のヘッダーをクリックして、キ

ーボードのデリートボタンを押す。 

 

変数変数変数変数のののの追加追加追加追加とととと削除削除削除削除    

 新しい変数を追加するには、Data→New Variableと選択する。新しい変数の名前を編集し、
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OKを押す。すると新しい変数がデータセットに現れる。 

 既存の変数の属性を変えたい場合は、列のヘッダーをクリックしてEdit Variableを選択する。 

� 変数の名前や説明(Description)を変えたい場合は、Edit Variableメニューで新しいものを入

力する。 

� 変数を完全に取り除くには、deleteボタンを押す。 

 

変数変数変数変数のののの変換変換変換変換    

 Edit VariableメニューのTransformation訳注3という項目では、もとのデータをMVQCAで使用

するデータに変換する方法を定義する。3つのオプションがあり、変数ごとに異なるオプション

を設定できる。 

� use 1:1:  このオプションでは、データがそのままの形でMVQCAに使われる。全てのデー

タは数値でなければならず、欠損値は -（ハイフン）で表さなければならないことに注意す

ること。事例の名前を含む変数は、次のCase IDの方の設定にするべきである。これらの条

件を満たさなければ、Tosmanaはエラーを返してしまう。 

� Case ID:  このオプションでは、変数は事例IDとしてのみ使用できる。 

� use thresholds: このオプションでは、後述の閾値設定ウィンドウ(ThresholdSetter)を使

うことができる。閾値設定ウインドウとは、Tosmanaで作業をしている間に、動的に閾値を

設定できる機能のことである。全てのデータは数値でなければならず、欠損値は -（ハイフ

ン）で表さなければならないことに注意すること。閾値は直接入力することもできるし、閾

値設定ウィンドウを使って設定することもできる。 

 

複数複数複数複数ののののデータデータデータデータ入力入力入力入力のののの置換置換置換置換    

 複数のセルを同じ値で置き換えたい場合には、置換ウィンドウを使えばよい(Data→Replace 

Values)。 置換する前の古い値と置換後の新しい値を定義し、置換を実施する変数の名前を全て

選択する。OKを押すと置換が実施される。この機能を使って、データセット中の欠損データを、

Tosmanaが要求する -（ハイフン）に一度に置き換えることができる。 

 

MVQCAMVQCAMVQCAMVQCA データデータデータデータへのへのへのへの変換変換変換変換    

 データをMVQCAの分析に適した変数に変換するには、閾値を設定してデータを再コーディン

グしなければならない。Tosmanaでは2つの方法がある。手動で閾値を直接設定する方法と、閾

値設定ウィンドウ(ThresholdSetter)を使ってインタラクティブに閾値を設定する方法である。 

 閾値を直接設定するには、閾値を設定しようとしている変数の列のヘッダーをクリックして、

Edit Variableを選択する。Conversionの項目でuse thresholdsを選択すると、setterというボタ

ンが使えるようになる。閾値では小数点を .（ドット）を使って表し、複数の閾値を入力すると

きは、;（セミコロン）を使う。 

 

閾値設定閾値設定閾値設定閾値設定ウィンドウウィンドウウィンドウウィンドウ((((ThresholdSetterThresholdSetterThresholdSetterThresholdSetter))))のののの使用使用使用使用    

                                                   
訳注 3 現在のバージョン 1.3.1では、Conversionという名前になっている。 
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 間隔尺度以上の尺度水準の変数がデータに含まれている場合、MVQCAを使う前にデータを順

序尺度に変換しなければならない。 

 

 

 ウィンドウの中央に表示されている図は、データの分布である。オレンジ色の四角は、事例１

つを表す。緑色の線は閾値を表す。show threshold valuesというオプションがセットされてい

れば、閾値の線の上に閾値の数字が表示される。また、小数点以下第何位まで表示するかは上の

図の3の部分で設定できる。赤色の太線はメディアンである（この線を表示するかどうかは上の

図の左下の2の部分で切り替えられる。） 

 閾値を動かすには、マウスを閾値の線の上に置き（マウスポインタが変化する）、マウスの左

ボタンを押せばよい。マウス（左ボタンを押し続けたまま）を動かすと線が動くので、希望の値

のところでマウスボタンを離す。 

 閾値の個数は、上の図の右上の1の部分にあるドロップダウンリストから選択できる。cluster

ボタンをクリックすると、簡単なクラスター分析（群平均法）が行われる。 

 

変数変数変数変数のののの再再再再コーディングコーディングコーディングコーディング    

 MVQCA用に変換した変数を新しい変数に再コーディングするには、メニューバーからData

→Recode Variableと選択する。再コーディングする変数を選択し、表示された新しい変数名の

候補をチェックしてOKを押す。新しく現れたウィンドウの左のボックスから「古い」値を選び、

新しい変数でそのままの値にする(「1:1」というボタンを押す）か、新しい値を割り振る（Convert 

toというボタンの下の欄に新しい値を入力し、Convert toボタンを押す）かを決定する。コーデ

ィングを取り消したい場合は、右のボックスから取り消したいものを選択し、undoボタンを押



 10 

す。 

 

5. 5. 5. 5. データデータデータデータ分析分析分析分析    

 Tosmanaの主要な目標は、2値や多値のデータの簡単化(minimization)である。これは、分析

ウィンドウ（(MV)QCAという名前がついている）で行われる。メニューバーから分析ウィンド

ウを呼び出すには、Analysis→Start (MV)QCAと選択する。 

 

図図図図    (MV)QCA(MV)QCA(MV)QCA(MV)QCAウィンドウウィンドウウィンドウウィンドウ（※訳注 現在のバージョンと多少異なる） 

    

分析分析分析分析するするするする条件条件条件条件のののの選択選択選択選択    

 計算をする前に、分析する条件を選択しなければならない（上の図の赤い四角で囲まれた１の

部分）。結果(outcome)と条件(condition)を選択するには矢印ボタンを使用する。事例ID(case 

descriptor)がTosmanaでは必要なことに注意すること。条件の値は、ブール代数の分析では{0,1}、

多値の分析では{0,...,n}でなければならない。数値でないデータを結果や条件として選択すると、

エラーウィンドウが現れる。 

 

データデータデータデータををををビジュアルビジュアルビジュアルビジュアル化化化化するするするする    

 5つまでの条件であれば、上図の2にあるVisualizeボタンを押すことでグラフを表示すること

ができる。後述のビジュアル化ウィンドウ(Visualizer)の章を参照。 

 

計算計算計算計算のののの方法方法方法方法のののの選択選択選択選択    
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 Tosmanaでは、解を計算する方法として次のような3つの異なる方法があり、上の図の3にあ

る選択モード(Selection Mode)のドロップダウンボックスから選択できる。 

 (1) 全ての解が計算されて結果レポートに表示される。 (Show All) 

         (2) 複数の解がある場合、使用する主項 (prime implicants)訳注4を、主項選択(Select  

  Prime Implicants)ウィンドウで選択できる。この場合、Tosmanaは解が最も簡単

  な形（最簡形、minimal）であることを保証してくれる。 (Select if possible) 

         (3) 主項選択(Select Prime Implicants)ウィンドウで自由に解を組み合わせることが

  できる。この場合、解は最簡形である必要はない。 (Free selection) 

 

計算計算計算計算のののの詳細詳細詳細詳細なななな設定設定設定設定    

 計算の詳細な設定は、上の図の(MV)QCAウィンドウの右側の4の部分で行うことができる訳注5。

上側の3つのラベルは次のような意味を持つ訳注6。 

� Explain: その解によって説明される結果（QCA2では、Matrix to be minimizedと呼ばれて

いた。） 

                                                   
訳注 4 prime implicantsは素項や素数的条件とも訳される。簡単化した（多値）ブール式の各項

は、これ以上簡単化できないという意味で素数(prime)的であるので、このように呼ばれる。 
訳注 5 （多値）ブール式の簡単化は、結果(outcome)の値が 0の場合と 1の場合、それから残余部

分(remainder)を含めるか含めないか、という 2種類の場合分けにより、計 4通りの場合の計算

を行うのが理想である。Rihoux and Ragin(2008:64)などを参照。Tosmanaの(MV)QCAウィン

ドウの 4の部分の Outcome 0と Outcome 1と Remaindersは、これを実現するためのものであ

る。なお、「残余部分(remainder)」とは、実際には事例がない条件の組み合わせを指す。「論理

残余(logical remainder)」とも呼ぶ。 
 また、結果の値が 0になる事例と結果の値が 1になる事例の双方が存在するような、「矛盾す

る条件の組み合わせ(Contradictions)」が真理表に存在する場合、それへの対処が必要になる。

Rihoux and Ragin(2008:48)などを参照。矛盾はなるべく事前に解決しておくのが望ましい。し

かし、矛盾を残したままにして、ブール式の簡単化を行う際に、矛盾する行の結果を全て 0と見

なしたり、矛盾する行を簡単化から排除したりすることもできる。それを実現するのが(MV)QCA
ウィンドウの 4の部分の Contradictionsである。 
  最後に、(MV)QCAウィンドウの 4の部分のMissing Valuesは、データに欠損のある場合の

対処法を指定するものである。 
訳注 6 Explainは、その（多値）ブール式が説明する結果を選択するものである。Outcome 0と

Outcome1については、通常は、どちらか一方のみ必ずこの設定を選択すべきである（そして通

常は、もう一方は Explainや Inclusion for reductionではなく、Excludeを選択すべきである）。

それに加え、ContradictionsやMissing Valuesについてこの選択をした場合には、Outcome 0
を Explainに設定している場合には、矛盾する条件の組み合わせや欠損した条件の組み合わせに

ついても結果の値が 0であるものと見なして簡単化がなされる。Outcome 1の方が Explainの

設定だった場合には、矛盾する条件の組み合わせや欠損した条件の組み合わせについても結果の

値が 1であるものと見なして簡単化がされる。 
 Outcome 0、Outcome 1、Contradictions、Missing Valuesを Inclusion for reductionの設定

にした場合には、対象は残余部分として扱われる。残余部分は事例のない条件の組み合わせであ

るので、どのような結果が生じるか予想して仮定をおくことになる。Remaindersを Inclusion for 
reductionの設定にした場合、上の 4つのうちで Inclusion for reductionの設定になっているも

のが、残余部分として簡単化の際に考慮されて、より簡潔な式になる可能性がある。逆に、上 4
つのうちで Excludeの設定になっているものは、簡単化の際に残余部分として考慮されること

はない。 
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� Include for reduction: 主項の縮約に含める結果（QCA2では、Matrix for computing Prime 

Implicantsと呼ばれていた。QCA2では、説明される結果が、このMatrix for computing 

Prime Implicantsに含まれていなければならなかったことに注意。QCA3ではdon't caresと

呼ばれる。） 

� Exclude: 簡単化から排除される結果。 

 

表記表記表記表記のののの選択選択選択選択    

 通常、Tosmanaは厳密な集合の表記を使って解の式を表現する。Use upper-case/lower-case

（大文字・小文字表記を使う訳注7）のオプションをセットすると、QCA2やQCA3のソフトで使

われている表記を代わりに使うことができる。 

 

主項主項主項主項のののの表示表示表示表示    

 主項のリストだけが欲しい場合は、上の図の6の部分にあるshow implicantsボタン訳注8を押す。

主項(Prime Implicants)ウィンドウが現れ、選択した条件と設定の下での主項を確認することが

できる。事例によってリストにフィルターをかけることができる。リスト中の主項をクリックす

ると、その主項がカバーしている事例を表示することができる。 

 

計算計算計算計算のののの開始開始開始開始    

 上の図の5のGoボタンを押すと計算が開始する。結果レポートが、インターネットエクスプロ

ーラーの新しいウィンドウで現れる訳注9。このウィンドウは保存したり印刷したりできる。 

 

主項主項主項主項のののの手動手動手動手動でのでのでのでの選択選択選択選択    

 主項選択(Select Prime Implicants)ウィンドウでは、主項が手動で選択できる。最簡形を見つ

けるにあたって複数の主項の間で選択が可能であるならば、それらがウィンドウの下側に表示さ

れる。すでに選択された主項はウィンドウの上側に表示される。これらの主項は、ユーザー自身

かまたはソフトウェアによって選択される。主項の選択は、最簡形の解にその主項を含まなけれ

ばならないということを意味している。緑色の列は、すでに選択された主項でカバーされていな

い事例を示すものである。 

 主項を選択するには、その主項の行をマウスでクリックすることで主項をハイライトして、use 

selected Implicantボタンを押せばよい。resetボタンを押すと、選択を取り消すことができる。

選択した主項で全ての事例がカバーされると、OKボタンを押せば結果レポートが呼び出せる。

cancelボタンを押すと、結果レポートを作成せずに主項選択(Select Prime Implicants)ウィンド

ウが閉じる。 

                                                   
訳注 7 値が 1である場合には大文字で記し、0である場合には小文字で記すような表記法。 
訳注 8 現在のバージョン 1.3.1では showボタンである。 
訳注 9 現在のバージョンでは、テキスト形式と HTML形式の 2つの形式で結果を表示できる。 
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TosmanaTosmanaTosmanaTosmana のののの結果結果結果結果レポートレポートレポートレポート    

 計算が終了すると、Tosmanaの結果(Result)ウィンドウか、選択によってはインターネットエ

クスプローラーで、結果レポートが開く。 
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 計算の設定と（もし選択していた場合は訳注10）データマトリックスが、レポートの先頭に表示

される。レポートの最後には、解と（オプションを設定していた場合は）単純化の仮定(simplifying 

assumptions)が表示される訳注11。以前のQCAのソフトと違って、Tosmanaでは、大文字・小文

字表記と厳密な集合の表記のどちらかを選択できる。Tosmanaでは条件を多値にできるが、大文

字・小文字表記は全ての条件が2値であるデータでのみ使用できる3。 

 レポートの全ての部分について、クリップボードにコピーして他のアプリケーションに貼り付

けることが可能である。マウスを右クリックして、ポップアップメニューからCopy textを選択

すればよい。 

 また、解をハイライトして、右クリックメニューからAdd to Boolean Calculatorを選択すると、

解をブール代数電卓(Boolean Calculator)に直接追加することができる4。 

 

6.6.6.6.    ビジュアルビジュアルビジュアルビジュアル化化化化ウィンドウウィンドウウィンドウウィンドウ    (The Visualizer)(The Visualizer)(The Visualizer)(The Visualizer)    

 Tosmanaでは、ブール型のデータセットについて、5個までの原因条件をグラフィカルに表示

できる。グラフィック表示を行うには、(MV)QCAウィンドウで条件を選択し、visualizeボタン

を押す。すると、ビジュアル化ウィンドウ(Visualizer)が現れる。 

                                                   
訳注 10 現在のバージョンでは、データマトリックスを表示するかを選択できるオプションは存在

しない。また、真理表は必ず表示されるようになっている。 
訳注 11 「単純化の仮定」とは、残余部分(remainder)の結果についての仮定である。残余部分には

事例がないので、論理残余を含めてブール式の簡単化を行う場合には、どのような結果が生じる

かを予想して仮定をおくことになるが、それを指している。 
3 社会科学におけるブール集合の使用についての最初の詳細な説明については、Ragin(1987)を
参照。また、その手法の適用についての入門書として、De Meur and Rihoux (2002) がある。

集合の表記は、Cronqvist(2003)で説明されている。 
4 現在は、これは 2値データの場合のみうまく機能する。また、結果レポートで集合の表記が使

われていなければならない（(MV)QCAウィンドウで Use upper-case/lower-caseのオプション

を選ばないこと）。 
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 現段階では、作成された図はビットマップ形式でのみ保存が可能である。ビットマップファイ

ルはサイズが非常に大きいが、ほとんどのグラフィックソフトで編集や圧縮が可能である。ビジ

ュアル化ウィンドウ(Visualizer)では、Color（カラー表示）とBlack/White（白黒表示）を切り

替えることや、表示する情報を選択することが可能である。また、主項や解をハイライトするこ

ともできる。 

 

7.7.7.7.    ブールブールブールブール代数代数代数代数電卓電卓電卓電卓    (The Boolean Calculator)(The Boolean Calculator)(The Boolean Calculator)(The Boolean Calculator)    

 ブール代数電卓(The Boolean Calculator)では、積集合や補集合といったブール式の単純な計

算を行うことができる。そのような計算を行うには、ブール式をブール代数電卓に入力しなけれ

ばならない。入力は普通の電卓と同じように中置記法で行われる。すなわち、最初に式を入力し

て、+や*でそれをつなげる。論理式が入力されたら、addボタンを押すことでそれが下の計算ボ

ックスに追加される。2つの論理式の積集合を計算するには、2つの式をリストから選択し（複数

の式を選択するにはシフトキーを使う）、Compute Intersection（積集合を計算）のボタンを押

す。ある論理式の補集合を計算するには、リストから式を選択してCompute Complement（補
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集合を計算）のボタンを押す。 

 バージョン1.25から、Tosmanaの結果レポートから直接に論理式を追加できるようになった

（本マニュアルの14ページを参照）。 

 

8. 8. 8. 8. 登録登録登録登録ととととサポートサポートサポートサポート    

 Tosmanaはフリーソフトウェアであり、プログラムのエラーが修正される保証はない。また、

Tosmanaはギブアンドテイクの考えに基づいている。すなわち、ソフトウェアは製作者によって

提供されるが、ユーザーはソフトウェアのエラーや新しいアイディアを報告することで、ソフト

ウェアを改善させることができる。そのために、Tosmana FAQ 

(http://www.tosmana.net/faq.html)を訪れていただきたい。 

 

登録登録登録登録訳注12 

 Tosmanaは無償だが、我々はどんな人がTosmanaを使っているのか知りたい。したがって、

http://register.tosmana.netにあるフォームを使って登録を行っていただきたい。登録していた

だくと、Tosmanaの変更をお知らせしたり、Tosmanaの使い方について質問がある場合にサポ

ートを頼んだりすることができる。登録した際、Tosmanaに入力する登録コードが発行される。 

 

アップデートアップデートアップデートアップデート    

 Tosmanaのアップデートについてお知らせするメーリングリストが設置されている

（http://www.tosmana.net/newslist.htmlを参照していただきたい。） 

 

9. 9. 9. 9. 引用引用引用引用、、、、テクニカルインフォメーションテクニカルインフォメーションテクニカルインフォメーションテクニカルインフォメーション、、、、連絡先連絡先連絡先連絡先    

 Tosmanaを使用する場合、次のように引用していただきたい。 

Cronqvist, Lasse. 2007. Tosmana – Tool for Small-N Analysis [Version 

1.3]. Marburg. <http://www.tosmana.net> 

 

 

 

 

 

 

 

 

 

                                                   
訳注 12 現在は登録は行われていない。 
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